Do I need a mobile phone for Nanit to work?

You’ll need a mobile phone or tablet to use Nanit, either iOS (version 8.0 and up) or Android (version 4.3 and up). 

Was this article helpful?
0 out of 0 found this helpful